Windows 7 & NWN

Home Forums Discussion Forums Out of Game Windows 7 & NWN

This topic contains 3 replies, has 4 voices, and was last updated by  Sarkhan July 4, 2010 at 5:26 am.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #33190

    s-m-r
    Moderator
    • Markshire PCs:

    After a few dozen tries with this game on a Windows 7 laptop I purchased earlier this year, I’ve found some issues with attempting to start the game. For those of you who choose to switch to this particular operating system, I have a few suggestions. Please note that the following may have been published in a NWN forum elsewhere; I don’t read them, and I hadn’t seen anything here, so I wanted to post the info in the hopes that it would be helpful to someone.

    An observation I’ve made is that, if you attempt to use the “normal” loading screen for NWN (via “nwn.exe,” the one with all the options, such as Play, Toolset, DM Client, etc.), the game simply doesn’t work. It’ll bring up the loading window (with the Neverwinter “eye” icon), and then crash.

    What seems to be the cause of this? The application called nwloader. I also strongly suspect that this is the CD check application…More about this later. But if you try to run the program by itself, the W7 application interface will list it as an incompatible program. Currently, I’ve not found any fixes for this…nor do I suspect any will be published.

    But, “How the heck do I start the game if it crashes when nwloader starts up?” you may be asking yourself. Well, here’s a work-around.

    TO PLAY THE GAME AND WORK-AROUND NWLOADER
    It’s simple! Create a shortcut to the application “nwmain.exe.” This bypasses nwloader and goes straight to running the game. I’ve also found that the game will work without the game CD/DVD in the disc drive when you do this.

    TO PLAY AS A DUNGEON MASTER/RUN THE DM CLIENT
    Again, this is also simple! Create a shortcut as above, but right-click on it, choose “Properties,” and in the command line, add this little bit: -dmc

    The shortcut command line should look something like this:

    C:NeverwinterNightsNWNnwmain.exe -dmc

    Incidentally, in both cases, the game starts without requiring the CD in the CD drive…It may chug a little bit, but that’s just due to the beginning movies at the start of the game. Click your left mouse button to bypass them.

    #58197

    BoostNJuice
    Moderator
    • Markshire PCs:

    I have this same problem with Vista….

    the shortcut works great

    boost

    #58198

    Monty
    Keymaster
    • Markshire PCs:

    You haven’t needed the CD to run NWN1 in years, as the code for the cd-check was disabled by Bioware after a few upgrades (I forget when, but Thrym knows).
    Also, have you tried running the game in Win-XP compatibility mode? It may work, but in any case your solution seems to solve the issue.

    M3C

    #58199

    Sarkhan
    Participant
    • Markshire PCs:

    I run it XP Compatible and as Administrator and I use the nwmain and toolset applications Shortcut to my desktop renamed Markshire.
    I also have other Versions of said short for each Install where I have just renamed the folder, ie Markshire I, NWN, and one other so i have 3 shortcuts for NWmain and 2 for toolsets and I don’t have any troubles.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.